What’s Vulnerable › Vulnerabilities
CVE-2019-14492
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-01 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in OpenCV before 3.4.7 and 4.x before 4.1.1. There is an out of bounds read/write in the function HaarEvaluator::OptFeature::calc in modules/objdetect/src/cascadedetect.hpp, which leads to denial of service.
Affected products
- OpenCV 3.0.0: before 3.4.7; from 4.0.0 before 4.1.1 — fixed in 3.4.7, 4.1.1
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: OpenCV 3.0.0 3.4.7, 4.1.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00025.html
- https://github.com/opencv/opencv/compare/33b765d...4a7ca5a
- https://github.com/opencv/opencv/compare/371bba8...ddbd10c
- https://github.com/opencv/opencv/issues/15124
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00025.html
- https://github.com/opencv/opencv/compare/33b765d...4a7ca5a
- https://github.com/opencv/opencv/compare/371bba8...ddbd10c
- https://github.com/opencv/opencv/issues/15124
Get alerted when CVE-2019-14492 or the next vulnerability affects your stack