What’s Vulnerable › Vulnerabilities
CVE-2019-14495
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-01 · updated 2026-06-17
- Weakness: CWE-787
Description
webadmin.c in 3proxy before 0.8.13 has an out-of-bounds write in the admin interface.
Affected products
- 3proxy: before 0.8.13 — fixed in 0.8.13
How to fix
Upgrade to a fixed version: 3proxy 0.8.13. Check the vendor advisory for mitigations.
References
- https://github.com/z3APA3A/3proxy/commit/3b67dc844789dc0f00e934270c7b349bcb547865
- https://github.com/z3APA3A/3proxy/compare/0.8.12...0.8.13
- https://github.com/z3APA3A/3proxy/releases/tag/0.8.13
- https://github.com/z3APA3A/3proxy/commit/3b67dc844789dc0f00e934270c7b349bcb547865
- https://github.com/z3APA3A/3proxy/compare/0.8.12...0.8.13
- https://github.com/z3APA3A/3proxy/releases/tag/0.8.13
Get alerted when CVE-2019-14495 or the next vulnerability affects your stack