What’s Vulnerable › Vulnerabilities
CVE-2019-14513
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-01 · updated 2026-06-17
- Weakness: CWE-125
Description
Improper bounds checking in Dnsmasq before 2.76 allows an attacker controlled DNS server to send large DNS packets that result in a read operation beyond the buffer allocated for the packet, a different vulnerability than CVE-2017-14491.
Affected products
- Debian Linux: 8.0
- Simon Kelley dnsmasq: before 2.76 — fixed in 2.76
How to fix
Upgrade to a fixed version: Simon Kelley dnsmasq 2.76. Check the vendor advisory for mitigations.
References
- https://github.com/Slovejoy/dnsmasq-pre2.76
- https://lists.debian.org/debian-lts-announce/2019/09/msg00013.html
- https://github.com/Slovejoy/dnsmasq-pre2.76
- https://lists.debian.org/debian-lts-announce/2019/09/msg00013.html
Get alerted when CVE-2019-14513 or the next vulnerability affects your stack