What’s Vulnerable › Vulnerabilities
CVE-2019-14525
- Severity: medium (CVSS 4.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-05 · updated 2026-06-17
Description
In Octopus Deploy 2019.4.0 through 2019.6.x before 2019.6.6, and 2019.7.x before 2019.7.6, an authenticated system administrator is able to view sensitive values by visiting a server configuration page or making an API call.
Affected products
- Octopus Deploy: from 2019.4.0 before 2019.6.6 — fixed in 2019.6.6
- Octopus Deploy Octopus Server: from 2019.7.0 before 2019.7.6 — fixed in 2019.7.6
How to fix
Upgrade to a fixed version: Octopus Deploy 2019.6.6; Octopus Deploy Octopus Server 2019.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/OctopusDeploy/Issues/issues/5753
- https://github.com/OctopusDeploy/Issues/issues/5754
- https://octopus.com/downloads/compare?from=2019.6.6&to=2019.7.7
- https://github.com/OctopusDeploy/Issues/issues/5753
- https://github.com/OctopusDeploy/Issues/issues/5754
- https://octopus.com/downloads/compare?from=2019.6.6&to=2019.7.7
Get alerted when CVE-2019-14525 or the next vulnerability affects your stack