What’s Vulnerable › Vulnerabilities
CVE-2019-14527
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-14 · updated 2026-06-17
- Weakness: CWE-78
Description
An issue was discovered on NETGEAR Nighthawk M1 (MR1100) devices before 12.06.03. System commands can be executed, via the web interface, after authentication.
Affected products
- NETGEAR Mr1100 Firmware: before 12.06.03 — fixed in 12.06.03
How to fix
Upgrade to a fixed version: NETGEAR Mr1100 Firmware 12.06.03. Check the vendor advisory for mitigations.
References
- https://www.pentestpartners.com/security-blog/how-not-to-do-cross-site-request-forgery-protection-the-netgear-nighthawk-m1/
- https://www.bleepingcomputer.com/news/security/4g-router-vulnerabilities-let-attackers-take-full-control/
- https://www.pentestpartners.com/security-blog/how-not-to-do-cross-site-request-forgery-protection-the-netgear-nighthawk-m1/
Get alerted when CVE-2019-14527 or the next vulnerability affects your stack