What’s Vulnerable › Vulnerabilities
CVE-2019-14530
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 65.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-13 · updated 2026-06-17
- Weakness: CWE-22
Description
An issue was discovered in custom/ajax_download.php in OpenEMR before 5.0.2 via the fileName parameter. An attacker can download any file (that is readable by the user www-data) from server storage. If the requested file is writable for the www-data user and the directory /var/www/openemr/sites/default/documents/cqm_qrda/ exists, it will be deleted from server.
Affected products
- openemr: before 5.0.2 — fixed in 5.0.2
How to fix
Upgrade to a fixed version: openemr 5.0.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/163215/OpenEMR-5.0.1.7-Path-Traversal.html
- http://packetstormsecurity.com/files/163375/OpenEMR-5.0.1.7-Path-Traversal.html
- https://github.com/Hacker5preme/Exploits/tree/main/CVE-2019-14530-Exploit
- https://github.com/Wezery/CVE-2019-14530
- https://github.com/openemr/openemr/pull/2592
- http://packetstormsecurity.com/files/163215/OpenEMR-5.0.1.7-Path-Traversal.html
- http://packetstormsecurity.com/files/163375/OpenEMR-5.0.1.7-Path-Traversal.html
- https://github.com/Hacker5preme/Exploits/tree/main/CVE-2019-14530-Exploit
- https://github.com/Wezery/CVE-2019-14530
- https://github.com/openemr/openemr/pull/2592
Get alerted when CVE-2019-14530 or the next vulnerability affects your stack