What’s Vulnerable › Vulnerabilities
CVE-2019-14549
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-05 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in EspoCRM before 5.6.9. Stored XSS was executed inside the title and breadcrumb of a newly formed entity available to all the users. A malicious user can inject JavaScript in these values of an entity, thus stealing user cookies when someone visits the publicly accessible link.
Affected products
- espocrm: before 5.6.9 — fixed in 5.6.9
How to fix
Upgrade to a fixed version: espocrm 5.6.9. Check the vendor advisory for mitigations.
References
- https://gauravnarwani.com/publications/cve-2019-14549/
- https://github.com/espocrm/espocrm/commit/ffd3f762ce4a8de3b8962f33513e073c55d943b5
- https://github.com/espocrm/espocrm/issues/1369
- https://github.com/espocrm/espocrm/releases/tag/5.6.9
- https://gauravnarwani.com/publications/cve-2019-14549/
- https://github.com/espocrm/espocrm/commit/ffd3f762ce4a8de3b8962f33513e073c55d943b5
- https://github.com/espocrm/espocrm/issues/1369
- https://github.com/espocrm/espocrm/releases/tag/5.6.9
Get alerted when CVE-2019-14549 or the next vulnerability affects your stack