What’s Vulnerable › Vulnerabilities
CVE-2019-14681
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-08 · updated 2026-06-17
- Weakness: CWE-352
Description
The Deny All Firewall plugin before 1.1.7 for WordPress allows wp-admin/options-general.php?page=daf_settings&daf_remove=true CSRF.
Affected products
- Deny All Firewall Project Deny All Firewall: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: Deny All Firewall Project Deny All Firewall 1.1.7. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/deny-all-firewall/#developers
- https://www.pluginvulnerabilities.com/2019/06/21/cross-site-request-forgery-csrf-vulnerability-in-deny-all-firewall/
- https://wordpress.org/plugins/deny-all-firewall/#developers
- https://www.pluginvulnerabilities.com/2019/06/21/cross-site-request-forgery-csrf-vulnerability-in-deny-all-firewall/
Get alerted when CVE-2019-14681 or the next vulnerability affects your stack