What’s Vulnerable › Vulnerabilities
CVE-2019-14771
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-08 · updated 2026-06-17
- Weakness: CWE-20
Description
Backdrop CMS 1.12.x before 1.12.8 and 1.13.x before 1.13.3 allows the upload of entire-site configuration archives through the user interface or command line. It does not sufficiently check uploaded archives for invalid data, potentially allowing non-configuration scripts to be uploaded to the server. (This attack is mitigated by the attacker needing the "Synchronize, import, and export configuration" permission, a permission that only trusted administrators should be given. Other preventative measures in Backdrop CMS prevent the execution of PHP scripts, so another server-side scripting language must be accessible on the server to execute code.) Note: This has been disputed by multiple 3rd parties due to advanced permissions that are needed to exploit.
Affected products
- BackdropCMS Backdrop: from 1.12.0 before 1.12.8; from 1.13.0 before 1.13.3 — fixed in 1.12.8, 1.13.3
How to fix
Upgrade to a fixed version: BackdropCMS Backdrop 1.12.8, 1.13.3. Check the vendor advisory for mitigations.
References
- https://backdropcms.org/security/backdrop-sa-core-2019-012
- https://backdropcms.org/security/backdrop-sa-core-2019-012
Get alerted when CVE-2019-14771 or the next vulnerability affects your stack