What’s Vulnerable › Vulnerabilities
CVE-2019-14785
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The "CP Contact Form with PayPal" plugin before 1.2.99 for WordPress has XSS in the publishing wizard via the wp-admin/admin.php?page=cp_contact_form_paypal.php&pwizard=1 cp_contactformpp_id parameter.
Affected products
- CodePeople, paypaldev CP Contact Form with Paypal: before 1.2.99 — fixed in 1.2.99
How to fix
Upgrade to a fixed version: CodePeople, paypaldev CP Contact Form with Paypal 1.2.99. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/cp-contact-form-with-paypal/#developers
- https://www.pluginvulnerabilities.com/2019/06/24/reflected-cross-site-scripting-xss-vulnerability-in-cp-contact-form-with-paypal/
- https://wordpress.org/plugins/cp-contact-form-with-paypal/#developers
- https://www.pluginvulnerabilities.com/2019/06/24/reflected-cross-site-scripting-xss-vulnerability-in-cp-contact-form-with-paypal/
Get alerted when CVE-2019-14785 or the next vulnerability affects your stack