What’s Vulnerable › Vulnerabilities
CVE-2019-14787
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Tribulant Newsletters plugin before 4.6.19 for WordPress allows XSS via the wp-admin/admin-ajax.php?action=newsletters_load_new_editor contentarea parameter.
Affected products
- contrid Newsletters: before 4.6.19 — fixed in 4.6.19
How to fix
Upgrade to a fixed version: contrid Newsletters 4.6.19. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/newsletters-lite/#developers
- https://wpvulndb.com/vulnerabilities/9447
- https://www.pluginvulnerabilities.com/2019/07/01/reflected-cross-site-scripting-xss-vulnerability-in-newsletters/
- https://wordpress.org/plugins/newsletters-lite/#developers
- https://wpvulndb.com/vulnerabilities/9447
- https://www.pluginvulnerabilities.com/2019/07/01/reflected-cross-site-scripting-xss-vulnerability-in-newsletters/
Get alerted when CVE-2019-14787 or the next vulnerability affects your stack