What’s Vulnerable › Vulnerabilities
CVE-2019-14816
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-20 · updated 2026-06-17
- Weakness: CWE-122
Description
There is heap-based buffer overflow in kernel, all versions up to, excluding 5.3, in the marvell wifi chip driver in Linux kernel, that allows local users to cause a denial of service(system crash) or possibly execute arbitrary code.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 19.04
- Debian Linux: 8.0
- Fedoraproject Fedora: 29, 30
- Linux kernel: from 3.6 before 3.16.74; from 3.17 before 4.4.194; from 4.5 before 4.9.194; from 4.10 before 4.14.146; from 4.15 before 4.19.75; from 4.20 before 5.2.17 — fixed in 3.16.74, 4.14.146, 4.19.75, 4.4.194, 4.9.194, 5.2.17
- NetApp A220 Firmware: all versions
- NetApp A320 Firmware: all versions
- NetApp A700S Firmware: all versions
- NetApp A800 Firmware: all versions
- NetApp C190 Firmware: all versions
- NetApp Data Availability Services: all versions
- NetApp Fas2720 Firmware: all versions
- NetApp Fas2750 Firmware: all versions
- NetApp H300E Firmware: all versions
- NetApp H300S Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500E Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H610S Firmware: all versions
- NetApp H700E Firmware: all versions
- NetApp H700S Firmware: all versions
- NetApp Hci Management Node: all versions
- NetApp, Inc. NetApp Service Processor: all versions
- NetApp Solidfire: all versions
- NetApp Steelstore Cloud Integrated Storage: all versions
- openSUSE Leap: 15.0, 15.1
- Red Hat Enterprise Linux: 5.0, 6.0, 6.4, 7.0, 7.6, 8.0
- RedHat Enterprise Linux Compute Node Eus: 7.6
- RedHat Enterprise Linux Eus: 7.6, 7.7, 8.1, 8.2, 8.4
- RedHat Enterprise Linux For Power Big Endian Eus: 7.6_ppc64
- RedHat Enterprise Linux For Real Time: 7, 8
How to fix
Upgrade to a fixed version: Linux kernel 3.16.74, 4.14.146, 4.19.75, 4.4.194. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- http://packetstormsecurity.com/files/154951/Kernel-Live-Patch-Security-Notice-LSN-0058-1.html
- http://packetstormsecurity.com/files/155212/Slackware-Security-Advisory-Slackware-14.2-kernel-Updates.html
- http://www.openwall.com/lists/oss-security/2019/08/28/1
- https://access.redhat.com/errata/RHSA-2020:0174
- https://access.redhat.com/errata/RHSA-2020:0204
- https://access.redhat.com/errata/RHSA-2020:0328
- https://access.redhat.com/errata/RHSA-2020:0339
- https://access.redhat.com/errata/RHSA-2020:0374
- https://access.redhat.com/errata/RHSA-2020:0375
- https://access.redhat.com/errata/RHSA-2020:0653
Get alerted when CVE-2019-14816 or the next vulnerability affects your stack