What’s Vulnerable › Vulnerabilities
CVE-2019-14822
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-25 · updated 2026-06-17
- Weakness: CWE-862
Description
A flaw was discovered in ibus in versions before 1.5.22 that allows any unprivileged user to monitor and send method calls to the ibus bus of another user due to a misconfiguration in the DBus server setup. A local attacker may use this flaw to intercept all keystrokes of a victim user who is using the graphical interface, change the input method engine, or modify other input related configurations of the victim user.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10
- Ibus Project Ibus: before 1.5.22 — fixed in 1.5.22
- Oracle Corporation Oracle ZFS Storage Appliance Kit: 8.8
- Red Hat Enterprise Linux: 7.0, 8.0
How to fix
Upgrade to a fixed version: Ibus Project Ibus 1.5.22. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1717958
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14822
- https://usn.ubuntu.com/4134-3/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1717958
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14822
- https://usn.ubuntu.com/4134-3/
- https://www.oracle.com/security-alerts/cpuapr2022.html
Get alerted when CVE-2019-14822 or the next vulnerability affects your stack