What’s Vulnerable › Vulnerabilities
CVE-2019-14832
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-15 · updated 2026-06-17
- Weakness: CWE-863
Description
A flaw was found in the Keycloak REST API before version 8.0.0 where it would permit user access from a realm the user was not configured. An authenticated attacker with knowledge of a user id could use this flaw to access unauthorized information or to carry out further attacks.
Affected products
- Keycloak: before 7.0.1 — fixed in 7.0.1
How to fix
Upgrade to a fixed version: Keycloak 7.0.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14832
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14832
Get alerted when CVE-2019-14832 or the next vulnerability affects your stack