What’s Vulnerable › Vulnerabilities

CVE-2019-14833

Description

A flaw was found in Samba, all versions starting samba 4.5.0 before samba 4.9.15, samba 4.10.10, samba 4.11.2, in the way it handles a user password change or a new password for a samba user. The Samba Active Directory Domain Controller can be configured to use a custom script to check for password complexity. This configuration can fail to verify password complexity when non-ASCII characters are used in the password, which could lead to weak passwords being set for samba users, making it vulnerable to dictionary attacks.

Affected products

How to fix

Upgrade to a fixed version: Samba 4.10.10, 4.11.2, 4.9.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-14833 or the next vulnerability affects your stack