What’s Vulnerable › Vulnerabilities
CVE-2019-14835
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-17 · updated 2026-06-17
- Weakness: CWE-120
Description
A buffer overflow flaw was found, in versions from 2.6.34 to 5.2.x, in the way Linux kernel's vhost functionality that translates virtqueue buffers to IOVs, logged the buffer descriptors during migration. A privileged guest user able to pass descriptors with invalid length to the host when migration is underway, could use this flaw to increase their privileges on the host.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.04
- Debian Linux: 8.0, 9.0, 10.0
- Fedoraproject Fedora: 29, 30
- Huawei Imanager Neteco: v600r009c00, v600r009c10spc200
- iManager NetEco 6000: v600r008c10spc300, v600r008c20
- ManageOne: 6.5.0, 6.5.0.spc100.b210, 6.5.1rc1.b060, 6.5.1rc1.b080, 6.5.rc2.b050
- Linux kernel: from 2.6.34 before 3.16.74; from 4.4 before 4.4.193; from 4.9 before 4.9.193; from 4.14 before 4.14.144; from 4.19 before 4.19.73; from 5.2 before 5.2.15 — fixed in 3.16.74, 4.14.144, 4.19.73, 4.4.193, 4.9.193, 5.2.15
- NetApp Aff A700S Firmware: all versions
- NetApp Data Availability Services: all versions
- NetApp H300E Firmware: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500E Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H610S Firmware: all versions
- NetApp H700E Firmware: all versions
- NetApp H700S Firmware: all versions
- NetApp Hci Management Node: all versions
- NetApp, Inc. NetApp Service Processor: all versions
- NetApp Solidfire: all versions
- NetApp Steelstore Cloud Integrated Storage: all versions
- openSUSE Leap: 15.0, 15.1
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Eus: 7.5, 7.6, 7.7
- RedHat Enterprise Linux For Real Time: 7, 8
- RedHat Enterprise Linux Server: 6.0, 7.0, 7.6
- RedHat Enterprise Linux Server Aus: 6.5, 6.6, 7.2, 7.3, 7.4, 7.6 (+1)
- RedHat Enterprise Linux Server Tus: 7.2, 7.3, 7.4, 7.6, 7.7
How to fix
Upgrade to a fixed version: Linux kernel 3.16.74, 4.14.144, 4.19.73, 4.4.193. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- http://packetstormsecurity.com/files/154572/Kernel-Live-Patch-Security-Notice-LSN-0056-1.html
- http://packetstormsecurity.com/files/154951/Kernel-Live-Patch-Security-Notice-LSN-0058-1.html
- http://packetstormsecurity.com/files/155212/Slackware-Security-Advisory-Slackware-14.2-kernel-Updates.html
- http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200115-01-qemu-en
- http://www.openwall.com/lists/oss-security/2019/09/24/1
- http://www.openwall.com/lists/oss-security/2019/10/03/1
- http://www.openwall.com/lists/oss-security/2019/10/09/3
- http://www.openwall.com/lists/oss-security/2019/10/09/7
- https://access.redhat.com/errata/RHBA-2019:2824
- https://access.redhat.com/errata/RHSA-2019:2827
Get alerted when CVE-2019-14835 or the next vulnerability affects your stack