What’s Vulnerable › Vulnerabilities
CVE-2019-14846
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-08 · updated 2026-06-17
- Weakness: CWE-117
Description
In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- openSUSE Backports Sle: 15.0-sp1
- openSUSE Leap: 15.1
- RedHat Ansible Engine: before 2.6.20; from 2.7.0 before 2.7.14; from 2.8.0 before 2.8.6; 2.0, 2.8.0 — fixed in 2.6.20, 2.7.14, 2.8.6
- OpenStack: 13
How to fix
Upgrade to a fixed version: RedHat Ansible Engine 2.6.20, 2.7.14, 2.8.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://access.redhat.com/errata/RHSA-2019:3201
- https://access.redhat.com/errata/RHSA-2019:3202
- https://access.redhat.com/errata/RHSA-2019:3203
- https://access.redhat.com/errata/RHSA-2019:3207
- https://access.redhat.com/errata/RHSA-2020:0756
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14846
- https://github.com/ansible/ansible/pull/63366
- https://lists.debian.org/debian-lts-announce/2020/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
- https://www.debian.org/security/2021/dsa-4950
Get alerted when CVE-2019-14846 or the next vulnerability affects your stack