What’s Vulnerable › Vulnerabilities
CVE-2019-14851
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-617
Description
A denial of service vulnerability was discovered in nbdkit. A client issuing a certain sequence of commands could possibly trigger an assertion failure, causing nbdkit to exit. This issue only affected nbdkit versions 1.12.7, 1.14.1, and 1.15.1.
Affected products
- nbdkit: before 1.12.7; from 1.14.0 before 1.14.1; from 1.15.0 before 1.15.1 — fixed in 1.12.7, 1.14.1, 1.15.1
How to fix
Upgrade to a fixed version: nbdkit 1.12.7, 1.14.1, 1.15.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1757259
- https://www.redhat.com/archives/libguestfs/2019-September/msg00272.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1757259
- https://www.redhat.com/archives/libguestfs/2019-September/msg00272.html
Get alerted when CVE-2019-14851 or the next vulnerability affects your stack