What’s Vulnerable › Vulnerabilities
CVE-2019-14859
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-02 · updated 2026-06-17
- Weakness: CWE-347
Description
A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted, making the signature malleable. Without proper verification, an attacker could use a malleable signature to create false transactions.
Affected products
- [UNKNOWN] python-ecdsa: before 0.13.3 — fixed in 0.13.3
- Red Hat Ceph Storage: 2.0, 3.0
- OpenStack: 10, 13, 14, 15
- RedHat Virtualization: 4.0
How to fix
Upgrade to a fixed version: [UNKNOWN] python-ecdsa 0.13.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14859
- https://github.com/warner/python-ecdsa/issues/114
- https://github.com/warner/python-ecdsa/releases/tag/python-ecdsa-0.13.3
- https://pypi.org/project/ecdsa/0.13.3/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14859
- https://github.com/warner/python-ecdsa/issues/114
- https://github.com/warner/python-ecdsa/releases/tag/python-ecdsa-0.13.3
- https://pypi.org/project/ecdsa/0.13.3/
Get alerted when CVE-2019-14859 or the next vulnerability affects your stack