What’s Vulnerable › Vulnerabilities
CVE-2019-14866
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-07 · updated 2026-06-17
- Weakness: CWE-20
Description
In all versions of cpio before 2.13 does not properly validate input files when generating TAR archives. When cpio is used to create TAR archives from paths an attacker can write to, the resulting archive may contain files with permissions the attacker did not have or in paths he did not have access to. Extracting those archives from a high-privilege user without carefully reviewing them may lead to the compromise of the system.
Affected products
- GNU cpio: before 2.13 — fixed in 2.13
- Red Hat Enterprise Linux: 7.0, 8.0
How to fix
Upgrade to a fixed version: GNU cpio 2.13. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14866
- https://lists.debian.org/debian-lts-announce/2023/06/msg00007.html
- https://lists.gnu.org/archive/html/bug-cpio/2019-08/msg00003.html
- https://lists.gnu.org/archive/html/bug-cpio/2019-11/msg00000.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14866
- https://lists.debian.org/debian-lts-announce/2023/06/msg00007.html
- https://lists.gnu.org/archive/html/bug-cpio/2019-08/msg00003.html
- https://lists.gnu.org/archive/html/bug-cpio/2019-11/msg00000.html
Get alerted when CVE-2019-14866 or the next vulnerability affects your stack