What’s Vulnerable › Vulnerabilities

CVE-2019-14867

Description

A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way the internal function ber_scanf() was used in some components of the IPA server, which parsed kerberos key data. An unauthenticated attacker who could trigger parsing of the krb principal key could cause the IPA server to crash or in some conditions, cause arbitrary code to be executed on the server hosting the IPA server.

Affected products

How to fix

Upgrade to a fixed version: FreeIPA ipa 4.6.7, 4.7.4, 4.8.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-14867 or the next vulnerability affects your stack