What’s Vulnerable › Vulnerabilities
CVE-2019-14868
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-02 · updated 2026-06-17
- Weakness: CWE-77
Description
In ksh version 20120801, a flaw was found in the way it evaluates certain environment variables. An attacker could use this flaw to override or bypass environment restrictions to execute shell commands. Services and applications that allow remote unauthenticated attackers to provide one of those environment variables could allow them to exploit this issue remotely.
Affected products
- macOS: before 10.15.5 — fixed in 10.15.5
- Debian Linux: 9.0
- Ksh Project Ksh: 20120801
How to fix
Upgrade to a fixed version: macOS 10.15.5. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2020/May/53
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14868
- https://github.com/att/ast/commit/c7de8b641266bac7c77942239ac659edfee9ecd2
- https://lists.debian.org/debian-lts-announce/2020/07/msg00015.html
- https://support.apple.com/kb/HT211170
- http://seclists.org/fulldisclosure/2020/May/53
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14868
- https://github.com/att/ast/commit/c7de8b641266bac7c77942239ac659edfee9ecd2
- https://lists.debian.org/debian-lts-announce/2020/07/msg00015.html
- https://support.apple.com/kb/HT211170
Get alerted when CVE-2019-14868 or the next vulnerability affects your stack