What’s Vulnerable › Vulnerabilities
CVE-2019-14869
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-15 · updated 2026-06-17
- Weakness: CWE-648
Description
A flaw was found in all versions of ghostscript 9.x before 9.50, where the `.charkeys` procedure, where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges within the Ghostscript and access files outside of restricted areas or execute commands.
Affected products
- Artifex Ghostscript: from 9.00 before 9.50 — fixed in 9.50
- Fedoraproject Fedora: 29, 30, 31
- openSUSE Leap: 15.0, 15.1
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.50. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN52486659/index.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00050.html
- http://www.openwall.com/lists/oss-security/2019/11/15/1
- https://access.redhat.com/errata/RHSA-2020:0222
- https://bugs.ghostscript.com/show_bug.cgi?id=701841
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14869
- https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=485904772c5f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2Q4E3OTDAJRSUCOBTDQO7Y5UTE2FFMLF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HC4REO73BEJOJAU7NHFHJECAUAYJUE3H/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IX55AEDERTDFEZAROKZW64MZRPLINEGI/
- https://seclists.org/bugtraq/2019/Nov/27
Get alerted when CVE-2019-14869 or the next vulnerability affects your stack