What’s Vulnerable › Vulnerabilities
CVE-2019-14870
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-10 · updated 2026-06-17
- Weakness: CWE-285
Description
All Samba versions 4.x.x before 4.9.17, 4.10.x before 4.10.11 and 4.11.x before 4.11.3 have an issue, where the S4U (MS-SFU) Kerberos delegation model includes a feature allowing for a subset of clients to be opted out of constrained delegation in any way, either S4U2Self or regular Kerberos authentication, by forcing all tickets for these clients to be non-forwardable. In AD this is implemented by a user attribute delegation_not_allowed (aka not-delegated), which translates to disallow-forwardable. However the Samba AD DC does not do that for S4U2Self and does set the forwardable flag even if the impersonated client has the not-delegated flag set.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 19.04, 19.10
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 30, 31
- openSUSE Leap: 15.1
- Samba: from 4.0.0 before 4.9.17; from 4.10.0 before 4.10.11; from 4.11.0 before 4.11.3 — fixed in 4.10.11, 4.11.3, 4.9.17
How to fix
Upgrade to a fixed version: Samba 4.10.11, 4.11.3, 4.9.17. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00038.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14870
- https://lists.debian.org/debian-lts-announce/2021/05/msg00023.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00034.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PJH3ROOFYMOATD2UEPC47P5RPBDTY77E/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WNKA4YIPV7AZR7KK3GW6L3HKGHSGJZFE/
- https://security.gentoo.org/glsa/202003-52
- https://security.gentoo.org/glsa/202310-06
- https://security.netapp.com/advisory/ntap-20191210-0002/
- https://security.netapp.com/advisory/ntap-20230216-0008/
- https://usn.ubuntu.com/4217-1/
- https://usn.ubuntu.com/4217-2/
Get alerted when CVE-2019-14870 or the next vulnerability affects your stack