What’s Vulnerable › Vulnerabilities
CVE-2019-14880
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-31 · updated 2026-06-17
- Weakness: CWE-287
Description
A vulnerability was found in Moodle versions 3.7 before 3.7.3, 3.6 before 3.6.7, 3.5 before 3.5.9 and earlier. OAuth 2 providers who do not verify users' email address changes require additional verification during sign-up to reduce the risk of account compromise.
Affected products
- Moodle: from 3.5 before 3.5.9; from 3.6 before 3.6.7; from 3.7 before 3.7.3 — fixed in 3.5.9, 3.6.7, 3.7.3
How to fix
Upgrade to a fixed version: Moodle 3.5.9, 3.6.7, 3.7.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14880
- https://moodle.org/security/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14880
- https://moodle.org/security/
Get alerted when CVE-2019-14880 or the next vulnerability affects your stack