What’s Vulnerable › Vulnerabilities
CVE-2019-14889
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-10 · updated 2026-06-17
- Weakness: CWE-78
Description
A flaw was found with the libssh API function ssh_scp_new() in versions before 0.9.3 and before 0.8.8. When the libssh SCP client connects to a server, the scp command, which includes a user-provided path, is executed on the server-side. In case the library is used in a way where users can influence the third parameter of the function, it would become possible for an attacker to inject arbitrary commands, leading to a compromise of the remote target.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04, 19.10
- Debian Linux: 8.0
- Fedoraproject Fedora: 30, 31
- libssh: before 0.8.8; from 0.9.0 before 0.9.3 — fixed in 0.8.8, 0.9.3
- openSUSE Leap: 15.1
- Oracle Corporation MySQL Workbench: through 8.0.19
How to fix
Upgrade to a fixed version: libssh 0.8.8, 0.9.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00047.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14889
- https://lists.debian.org/debian-lts-announce/2019/12/msg00020.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00029.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7JJWJTXVWLLJTVHBPGWL7472S5FWXYQR/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/EV2ONSPDJCTDVORCB4UGRQUZQQ46JHRN/
- https://security.gentoo.org/glsa/202003-27
- https://usn.ubuntu.com/4219-1/
- https://www.libssh.org/security/advisories/CVE-2019-14889.txt
- https://www.oracle.com/security-alerts/cpuapr2020.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00033.html
Get alerted when CVE-2019-14889 or the next vulnerability affects your stack