What’s Vulnerable › Vulnerabilities

CVE-2019-14901

Description

A heap overflow flaw was found in the Linux kernel, all versions 3.x.x and 4.x.x before 4.18.0, in Marvell WiFi chip driver. The vulnerability allows a remote attacker to cause a system crash, resulting in a denial of service, or execute arbitrary code. The highest threat with this vulnerability is with the availability of the system. If code execution occurs, the code will run with the permissions of root. This will affect both confidentiality and integrity of files on the system.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.16.83, 4.14.164, 4.19.95, 4.4.217. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-14901 or the next vulnerability affects your stack