What’s Vulnerable › Vulnerabilities
CVE-2019-14902
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-21 · updated 2026-06-17
- Weakness: CWE-284
Description
There is an issue in all samba 4.11.x versions before 4.11.5, all samba 4.10.x versions before 4.10.12 and all samba 4.9.x versions before 4.9.18, where the removal of the right to create or modify a subtree would not automatically be taken away on all domain controllers.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04, 19.10
- Debian Linux: 9.0
- openSUSE Leap: 15.1
- Samba: from 4.0.0 before 4.9.18; from 4.10.0 before 4.10.12; from 4.11.0 before 4.11.5 — fixed in 4.10.12, 4.11.5, 4.9.18
How to fix
Upgrade to a fixed version: Samba 4.10.12, 4.11.5, 4.9.18. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00055.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14902
- https://lists.debian.org/debian-lts-announce/2021/05/msg00023.html
- https://lists.debian.org/debian-lts-announce/2023/09/msg00013.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4ACZVNMIFQGGXNJPMHAVBN3H2U65FXQY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GQ6U65I2K23YJC4FESW477WL55TU3PPT/
- https://security.gentoo.org/glsa/202003-52
- https://security.netapp.com/advisory/ntap-20200122-0001/
- https://usn.ubuntu.com/4244-1/
- https://www.samba.org/samba/security/CVE-2019-14902.html
- https://www.synology.com/security/advisory/Synology_SA_20_01
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00055.html
Get alerted when CVE-2019-14902 or the next vulnerability affects your stack