What’s Vulnerable › Vulnerabilities
CVE-2019-14904
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-26 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in the solaris_zone module from the Ansible Community modules. When setting the name for the zone on the Solaris host, the zone name is checked by listing the process with the 'ps' bare command on the remote machine. An attacker could take advantage of this flaw by crafting the name of the zone and executing arbitrary commands in the remote host. Ansible Engine 2.7.15, 2.8.7, and 2.9.2 as well as previous versions are affected.
Affected products
- Debian Linux: 9.0, 10.0
- Red Hat Ansible: before 2.7.15; from 2.8.0 before 2.8.7; from 2.9.0 before 2.9.2 — fixed in 2.7.15, 2.8.7, 2.9.2
How to fix
Upgrade to a fixed version: Red Hat Ansible 2.7.15, 2.8.7, 2.9.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1776944
- https://github.com/ansible/ansible/pull/65686
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
- https://www.debian.org/security/2021/dsa-4950
- https://bugzilla.redhat.com/show_bug.cgi?id=1776944
- https://github.com/ansible/ansible/pull/65686
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
- https://www.debian.org/security/2021/dsa-4950
Get alerted when CVE-2019-14904 or the next vulnerability affects your stack