What’s Vulnerable › Vulnerabilities
CVE-2019-14946
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The ultimate-member plugin before 2.0.52 for WordPress has XSS related to UM Roles create and edit operations.
Affected products
- ultimatemember Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership P: before 2.0.52 — fixed in 2.0.52
How to fix
Upgrade to a fixed version: ultimatemember Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership P 2.0.52. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/ultimate-member/#developers
- https://wpvulndb.com/vulnerabilities/9449
- https://wordpress.org/plugins/ultimate-member/#developers
- https://wpvulndb.com/vulnerabilities/9449
Get alerted when CVE-2019-14946 or the next vulnerability affects your stack