What’s Vulnerable › Vulnerabilities
CVE-2019-14948
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The woocommerce-product-addon plugin before 18.4 for WordPress has XSS via an import of a new meta data structure.
Affected products
- PPOM for WooCommerce: before 18.4 — fixed in 18.4
How to fix
Upgrade to a fixed version: PPOM for WooCommerce 18.4. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/woocommerce-product-addon/#developers
- https://wpvulndb.com/vulnerabilities/9502
- https://www.pluginvulnerabilities.com/2019/08/08/this-authenticated-persistent-xss-vulnerability-might-be-what-hackers-are-targeting-ppom-for-woocommerce-for/
- https://wordpress.org/plugins/woocommerce-product-addon/#developers
- https://wpvulndb.com/vulnerabilities/9502
- https://www.pluginvulnerabilities.com/2019/08/08/this-authenticated-persistent-xss-vulnerability-might-be-what-hackers-are-targeting-ppom-for-woocommerce-for/
Get alerted when CVE-2019-14948 or the next vulnerability affects your stack