What’s Vulnerable › Vulnerabilities
CVE-2019-14965
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-12 · updated 2026-06-17
- Weakness: CWE-94
Description
An issue was discovered in Frappe Framework 10 through 12 before 12.0.4. A server side template injection (SSTI) issue exists.
Affected products
- frappe: from 10.0.0 before 12.0.4 — fixed in 12.0.4
How to fix
Upgrade to a fixed version: frappe 12.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/compare/v12.0.3...v12.0.4
- https://github.com/frappe/frappe/pull/8044
- https://github.com/frappe/frappe/pull/8045
- https://github.com/frappe/frappe/pull/8046
- https://github.com/frappe/frappe/pull/8047
- https://github.com/frappe/frappe/releases/tag/v12.0.4
- https://github.com/frappe/frappe/compare/v12.0.3...v12.0.4
- https://github.com/frappe/frappe/pull/8044
- https://github.com/frappe/frappe/pull/8045
- https://github.com/frappe/frappe/pull/8046
- https://github.com/frappe/frappe/pull/8047
- https://github.com/frappe/frappe/releases/tag/v12.0.4
Get alerted when CVE-2019-14965 or the next vulnerability affects your stack