What’s Vulnerable › Vulnerabilities
CVE-2019-14980
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-12 · updated 2026-06-17
- Weakness: CWE-416
Description
In ImageMagick 7.x before 7.0.8-42 and 6.x before 6.9.10-42, there is a use after free vulnerability in the UnmapBlob function that allows an attacker to cause a denial of service by sending a crafted file.
Affected products
- ImageMagick: from 6.0 before 6.9.10-42; from 7.0.0-0 before 7.0.8-42 — fixed in 6.9.10-42, 7.0.8-42
- openSUSE Leap: 15.0, 15.1
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-42, 7.0.8-42. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00042.html
- https://github.com/ImageMagick/ImageMagick/commit/c5d012a46ae22be9444326aa37969a3f75daa3ba
- https://github.com/ImageMagick/ImageMagick/compare/7.0.8-41...7.0.8-42
- https://github.com/ImageMagick/ImageMagick6/commit/614a257295bdcdeda347086761062ac7658b6830
- https://github.com/ImageMagick/ImageMagick6/issues/43
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00042.html
- https://github.com/ImageMagick/ImageMagick/commit/c5d012a46ae22be9444326aa37969a3f75daa3ba
- https://github.com/ImageMagick/ImageMagick/compare/7.0.8-41...7.0.8-42
- https://github.com/ImageMagick/ImageMagick6/commit/614a257295bdcdeda347086761062ac7658b6830
- https://github.com/ImageMagick/ImageMagick6/issues/43
Get alerted when CVE-2019-14980 or the next vulnerability affects your stack