What’s Vulnerable › Vulnerabilities
CVE-2019-14982
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-12 · updated 2026-06-17
- Weakness: CWE-190
Description
In Exiv2 before v0.27.2, there is an integer overflow vulnerability in the WebPImage::getHeaderOffset function in webpimage.cpp. It can lead to a buffer overflow vulnerability and a crash.
Affected products
- exiv2: before 0.27.2 — fixed in 0.27.2
How to fix
Upgrade to a fixed version: exiv2 0.27.2. Check the vendor advisory for mitigations.
References
- https://github.com/Exiv2/exiv2/compare/v0.27.2-RC2...v0.27.2
- https://github.com/Exiv2/exiv2/issues/960
- https://github.com/Exiv2/exiv2/pull/962/commits/e925bc5addd881543fa503470c8a859e112cca62
- https://github.com/Exiv2/exiv2/compare/v0.27.2-RC2...v0.27.2
- https://github.com/Exiv2/exiv2/issues/960
- https://github.com/Exiv2/exiv2/pull/962/commits/e925bc5addd881543fa503470c8a859e112cca62
Get alerted when CVE-2019-14982 or the next vulnerability affects your stack