What’s Vulnerable › Vulnerabilities
CVE-2019-15090
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-16 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in drivers/scsi/qedi/qedi_dbg.c in the Linux kernel before 5.1.12. In the qedi_dbg_* family of functions, there is an out-of-bounds read.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10
- Linux kernel: before 5.1.12 — fixed in 5.1.12
- openSUSE Leap: 15.0, 15.1
How to fix
Upgrade to a fixed version: Linux kernel 5.1.12. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.1.12
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=c09581a52765a85f19fc35340127396d5e3379cc
- https://github.com/torvalds/linux/commit/c09581a52765a85f19fc35340127396d5e3379cc
- https://security.netapp.com/advisory/ntap-20190905-0002/
- https://usn.ubuntu.com/4115-1/
- https://usn.ubuntu.com/4118-1/
- https://usn.ubuntu.com/4147-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.1.12
Get alerted when CVE-2019-15090 or the next vulnerability affects your stack