What’s Vulnerable › Vulnerabilities
CVE-2019-15133
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-17 · updated 2026-06-17
- Weakness: CWE-369
Description
In GIFLIB before 2019-02-16, a malformed GIF file triggers a divide-by-zero exception in the decoder function DGifSlurp in dgif_lib.c if the height field of the ImageSize data structure is equal to zero.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04
- Debian Linux: 10.0
- giflib: before 5.1.7 — fixed in 5.1.7
How to fix
Upgrade to a fixed version: giflib 5.1.7. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=13008
- https://lists.debian.org/debian-lts-announce/2022/12/msg00008.html
- https://usn.ubuntu.com/4107-1/
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=13008
- https://lists.debian.org/debian-lts-announce/2022/12/msg00008.html
- https://usn.ubuntu.com/4107-1/
Get alerted when CVE-2019-15133 or the next vulnerability affects your stack