What’s Vulnerable › Vulnerabilities
CVE-2019-15138
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-20 · updated 2026-06-17
- Weakness: CWE-668
Description
The html-pdf package 2.2.0 for Node.js has an arbitrary file read vulnerability via an HTML file that uses XMLHttpRequest to access a file:/// URL.
Affected products
- Html-Pdf Project Html-Pdf: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: Html-Pdf Project Html-Pdf 3.0.1. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20191017-0005/
- https://www.npmjs.com/advisories/1095
- https://security.netapp.com/advisory/ntap-20191017-0005/
- https://www.npmjs.com/advisories/1095
Get alerted when CVE-2019-15138 or the next vulnerability affects your stack