What’s Vulnerable › Vulnerabilities
CVE-2019-15166: lmp_print in tcpdump lacks certain boundary checks
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-03 · updated 2026-06-17
- Weakness: CWE-120
Description
lmp_print_data_link_subobjs() in print-lmp.c in tcpdump before 4.9.3 lacks certain bounds checks.
Affected products
- macOS: before 10.15.2 — fixed in 10.15.2
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0, 10.0
- Fedoraproject Fedora: 29, 30, 31
- NetApp Cloud Backup: all versions
- NetApp Hci Management Node: all versions
- NetApp Solidfire: all versions
- openSUSE Leap: 15.0, 15.1
- Red Hat Enterprise Linux: 7.0, 8.0
- The Tcpdump Group tcpdump: before 4.9.3 — fixed in 4.9.3
How to fix
Upgrade to a fixed version: macOS 10.15.2; The Tcpdump Group tcpdump 4.9.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00050.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00053.html
- http://seclists.org/fulldisclosure/2019/Dec/26
- https://github.com/the-tcpdump-group/tcpdump/blob/tcpdump-4.9/CHANGES
- https://github.com/the-tcpdump-group/tcpdump/commit/0b661e0aa61850234b64394585cf577aac570bf4
- https://lists.debian.org/debian-lts-announce/2019/10/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/62XY42U6HY3H2APR5EHNWCZ7SAQNMMJN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FNYXF3IY2X65IOD422SA6EQUULSGW7FN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R2UDPOSGVJQIYC33SQBXMDXHH4QDSDMU/
- https://seclists.org/bugtraq/2019/Dec/23
- https://seclists.org/bugtraq/2019/Oct/28
- https://security.netapp.com/advisory/ntap-20200120-0001/
Get alerted when CVE-2019-15166 or the next vulnerability affects your stack