What’s Vulnerable › Vulnerabilities
CVE-2019-15167
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-27 · updated 2026-06-17
- Weakness: CWE-125
Description
The VRRP parser in tcpdump before 4.9.3 has a buffer over-read in print-vrrp.c:vrrp_print() for VRRP version 3, a different vulnerability than CVE-2018-14463.
Affected products
- The Tcpdump Group tcpdump: before 4.9.3 — fixed in 4.9.3
How to fix
Upgrade to a fixed version: The Tcpdump Group tcpdump 4.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/the-tcpdump-group/tcpdump/commit/a152aebfd1114376ba266ed30416be596ef9d806
- https://github.com/the-tcpdump-group/tcpdump/commit/a152aebfd1114376ba266ed30416be596ef9d806
Get alerted when CVE-2019-15167 or the next vulnerability affects your stack