What’s Vulnerable › Vulnerabilities
CVE-2019-15215
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-19 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the Linux kernel before 5.2.6. There is a use-after-free caused by a malicious USB device in the drivers/media/usb/cpia2/cpia2_usb.c driver.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04
- Debian Linux: 8.0
- Linux kernel: before 5.2.6 — fixed in 5.2.6
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- NetApp Data Availability Services: all versions
- NetApp H410C Firmware: all versions
- NetApp Solidfire & Hci Management Node: all versions
- NetApp Solidfire Baseboard Management Controller: all versions
- openSUSE Leap: 15.0, 15.1
How to fix
Upgrade to a fixed version: Linux kernel 5.2.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- http://www.openwall.com/lists/oss-security/2019/08/20/2
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.6
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=eff73de2b1600ad8230692f00bc0ab49b166512a
- https://lists.debian.org/debian-lts-announce/2019/09/msg00014.html
- https://lists.debian.org/debian-lts-announce/2019/09/msg00015.html
- https://lists.debian.org/debian-lts-announce/2019/09/msg00025.html
- https://security.netapp.com/advisory/ntap-20190905-0002/
- https://syzkaller.appspot.com/bug?id=b68d3c254cf294f8a802582094fa3251d6de5247
- https://usn.ubuntu.com/4115-1/
- https://usn.ubuntu.com/4118-1/
Get alerted when CVE-2019-15215 or the next vulnerability affects your stack