What’s Vulnerable › Vulnerabilities
CVE-2019-15249: Cisco SPA100 Series Analog Telephone Adapters Remote Code Execution Vulnerabilities
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-16 · updated 2026-06-17
- Weakness: CWE-119
Description
Multiple vulnerabilities in Cisco SPA100 Series Analog Telephone Adapters (ATAs) could allow an authenticated, adjacent attacker to execute arbitrary code with elevated privileges. The vulnerabilities are due to improper validation of user-supplied input to the web-based management interface. An attacker could exploit these vulnerabilities by authenticating to the web-based management interface and sending crafted requests to an affected device. A successful exploit could allow the attacker to execute arbitrary code with elevated privileges. Note: The web-based management interface is enabled by default.
Affected products
- Cisco Spa112 Firmware: before 1.4.1; 1.4.1, 1.4.1-sr1, 1.4.1-sr2, 1.4.1-sr3, 1.4.1-sr4 — fixed in 1.4.1
- Cisco SPA122 ATA with Router: before 1.4.1; 1.4.1, 1.4.1-sr1, 1.4.1-sr2, 1.4.1-sr3, 1.4.1-sr4 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: Cisco Spa112 Firmware 1.4.1; Cisco SPA122 ATA with Router 1.4.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191016-spa-rce
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191016-spa-rce
Get alerted when CVE-2019-15249 or the next vulnerability affects your stack