What’s Vulnerable › Vulnerabilities
CVE-2019-15256: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software IKEv1 Denial of Service Vulnerability
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-02 · updated 2026-08-11
- Weakness: CWE-399
Description
A vulnerability in the Internet Key Exchange version 1 (IKEv1) feature of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to trigger a reload of an affected device, resulting in a denial of service (DoS) condition. The vulnerability is due to improper management of system memory. An attacker could exploit this vulnerability by sending malicious IKEv1 traffic to an affected device. The attacker does not need valid credentials to authenticate the VPN session, nor does the attacker's source address need to match a peer statement in the crypto map applied to the ingress interface of the affected device. An exploit could allow the attacker to exhaust system memory resources, leading to a reload of an affected device.
Affected products
- Cisco ASA Software: from 9.7 before 9.8.4.10; from 9.9 before 9.9.2.47; from 9.10 before 9.10.1.30; from 9.12 before 9.12.2.5 — fixed in 9.10.1.30, 9.12.2.5, 9.8.4.10, 9.9.2.47
- Cisco Asa 5505 Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Asa 5510 Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Asa 5512-X Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Asa 5515-X Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Asa 5520 Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Asa 5525-X Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Asa 5540 Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Asa 5545-X Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Asa 5550 Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Asa 5555-X Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Asa 5580 Firmware: 9.9(2.4), 201.4(1.21)
- Cisco Firepower Threat Defense Software: from 6.2.0 before 6.2.3.11; from 6.3.0 before 6.3.0.2 — fixed in 6.2.3.11, 6.3.0.2
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.10.1.30, 9.12.2.5, 9.8.4.10, 9.9.2.47; Cisco Firepower Threat Defense Software 6.2.3.11, 6.3.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-asa-ftd-ikev1-dos
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191002-asa-ftd-ikev1-dos
Get alerted when CVE-2019-15256 or the next vulnerability affects your stack