What’s Vulnerable › Vulnerabilities
CVE-2019-15277: Cisco TelePresence Collaboration Endpoint Software Privilege Escalation Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-16 · updated 2026-06-17
- Weakness: CWE-264
Description
A vulnerability in the CLI of Cisco TelePresence Collaboration Endpoint (CE) Software could allow an authenticated, local attacker to execute code with root privileges. The vulnerability is due to insufficient input validation. An attacker could exploit this vulnerability by authenticating as the remote support user and sending malicious traffic to a listener who is internal to the device. A successful exploit could allow the attacker to execute commands with root privileges.
Affected products
- Cisco TelePresence Endpoint Software (TC/CE): before 9.8.0 — fixed in 9.8.0
How to fix
Upgrade to a fixed version: Cisco TelePresence Endpoint Software (TC/CE) 9.8.0. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191016-telepres-escalation
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191016-telepres-escalation
Get alerted when CVE-2019-15277 or the next vulnerability affects your stack