What’s Vulnerable › Vulnerabilities
CVE-2019-15292
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-21 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the Linux kernel before 5.0.9. There is a use-after-free in atalk_proc_exit, related to net/appletalk/atalk_proc.c, net/appletalk/ddp.c, and net/appletalk/sysctl_net_atalk.c.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04
- Debian Linux: 8.0
- Linux kernel: before 3.16.74; from 3.17 before 3.18.139; from 3.19 before 4.4.179; from 4.5 before 4.9.170; from 4.10 before 4.14.113; from 4.15 before 4.19.36 — fixed in 3.16.74, 3.18.139, 4.14.113, 4.19.36, 4.4.179, 4.9.170
How to fix
Upgrade to a fixed version: Linux kernel 3.16.74, 3.18.139, 4.14.113, 4.19.36. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.0.9
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=6377f787aeb945cae7abbb6474798de129e1f3ac
- https://lists.debian.org/debian-lts-announce/2019/09/msg00014.html
- https://lists.debian.org/debian-lts-announce/2019/09/msg00015.html
- https://lists.debian.org/debian-lts-announce/2019/09/msg00025.html
- https://security.netapp.com/advisory/ntap-20190905-0002/
- https://support.f5.com/csp/article/K27112954
- https://support.f5.com/csp/article/K27112954?utm_source=f5support&%3Butm_medium=RSS
- https://usn.ubuntu.com/4115-1/
- https://usn.ubuntu.com/4118-1/
Get alerted when CVE-2019-15292 or the next vulnerability affects your stack