What’s Vulnerable › Vulnerabilities
CVE-2019-15488
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Ignite Realtime Openfire before 4.4.1 has reflected XSS via an LDAP setup test.
Affected products
- igniterealtime Openfire: before 4.4.1 — fixed in 4.4.1
How to fix
Upgrade to a fixed version: igniterealtime Openfire 4.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/igniterealtime/Openfire/compare/cd0a573...5e5d9e5
- https://github.com/igniterealtime/Openfire/pull/1441
- https://github.com/igniterealtime/Openfire/compare/cd0a573...5e5d9e5
- https://github.com/igniterealtime/Openfire/pull/1441
Get alerted when CVE-2019-15488 or the next vulnerability affects your stack