What’s Vulnerable › Vulnerabilities
CVE-2019-15507
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-23 · updated 2026-06-17
- Weakness: CWE-312
Description
In Octopus Deploy versions 2018.8.4 to 2019.7.6, when a web request proxy is configured, an authenticated user (in certain limited special-characters circumstances) could trigger a deployment that writes the web request proxy password to the deployment log in cleartext. This is fixed in 2019.7.7. The fix was back-ported to LTS 2019.6.7 as well as LTS 2019.3.8.
Affected products
- Octopus Server: from 2018.8.4 through 2019.7.6
References
- https://github.com/OctopusDeploy/Issues/issues/5761
- https://github.com/OctopusDeploy/Issues/issues/5761
Get alerted when CVE-2019-15507 or the next vulnerability affects your stack