What’s Vulnerable › Vulnerabilities
CVE-2019-15508
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-23 · updated 2026-06-17
- Weakness: CWE-312
Description
In Octopus Tentacle versions 3.0.8 to 5.0.0, when a web request proxy is configured, an authenticated user (in certain limited OctopusPrintVariables circumstances) could trigger a deployment that writes the web request proxy password to the deployment log in cleartext. This is fixed in 5.0.1. The fix was back-ported to 4.0.7.
Affected products
- Octopus Server: from 3.0.8 through 2019.7.6
- Octopus Deploy Octopus Tentacle: from 3.0.8 through 5.0.0
References
- https://github.com/OctopusDeploy/Issues/issues/5750
- https://github.com/OctopusDeploy/Issues/issues/5750
Get alerted when CVE-2019-15508 or the next vulnerability affects your stack