What’s Vulnerable › Vulnerabilities
CVE-2019-1551: rsaz_512_sqr overflow bug on x86_64
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-06 · updated 2026-10-08
- Weakness: CWE-190
Description
There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME. Fixed in OpenSSL 1.1.1e (Affected 1.1.1-1.1.1d). Fixed in OpenSSL 1.0.2u (Affected 1.0.2-1.0.2t).
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 30, 31, 32
- OpenSSL: from 1.0.2 through 1.0.2t; from 1.1.1 through 1.1.1d
- openSUSE Leap: 15.1
- Oracle Corporation Enterprise Manager Ops Center: 12.4.0.0
- Oracle Corporation MySQL Enterprise Monitor: through 4.0.12; from 8.0.0 through 8.0.20
- Oracle Corporation PeopleSoft Enterprise PT PeopleTools: 8.56, 8.57, 8.58
- Tenable Log Correlation Engine: before 6.0.9 — fixed in 6.0.9
How to fix
Upgrade to a fixed version: Tenable Log Correlation Engine 6.0.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00030.html
- http://packetstormsecurity.com/files/155754/Slackware-Security-Advisory-openssl-Updates.html
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=419102400a2811582a7a3d4a4e317d72e5ce0a8f
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=f1c5eea8a817075d31e43f5876993c6710238c98
- https://lists.debian.org/debian-lts-announce/2022/03/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DDHOAATPWJCXRNFMJ2SASDBBNU5RJONY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/EXDDAOWSAIEFQNBHWYE6PPYFV4QXGMCD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XVEP3LAK4JSPRXFO4QF4GG2IVXADV3SO/
- https://seclists.org/bugtraq/2019/Dec/39
- https://seclists.org/bugtraq/2019/Dec/46
- https://security.gentoo.org/glsa/202004-10
- https://security.netapp.com/advisory/ntap-20191210-0001/
Get alerted when CVE-2019-1551 or the next vulnerability affects your stack