What’s Vulnerable › Vulnerabilities
CVE-2019-15518
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-23 · updated 2026-06-17
- Weakness: CWE-22
Description
Swoole before 4.2.13 allows directory traversal in swPort_http_static_handler.
Affected products
- Swoole: before 4.2.13 — fixed in 4.2.13
How to fix
Upgrade to a fixed version: Swoole 4.2.13. Check the vendor advisory for mitigations.
References
- https://github.com/swoole/swoole-src/compare/v4.2.12...v4.2.13
- https://github.com/swoole/swoole-src/pull/2323
- https://github.com/swoole/swoole-src/compare/v4.2.12...v4.2.13
- https://github.com/swoole/swoole-src/pull/2323
Get alerted when CVE-2019-15518 or the next vulnerability affects your stack