What’s Vulnerable › Vulnerabilities
CVE-2019-15525
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-23 · updated 2026-06-17
- Weakness: CWE-295
Description
There is Missing SSL Certificate Validation in the pw3270 terminal emulator before version 5.1.
Affected products
- Pw3270 Project Pw3270: before 5.1 — fixed in 5.1
How to fix
Upgrade to a fixed version: Pw3270 Project Pw3270 5.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2019/08/26/1
- https://softwarepublico.gov.br/gitlab/pw3270/principal/compare/efa4ab249821ec351ae986683371043b8ca3c2ea...ff2b10fd56cf1fdae862b44bb0610e20e08de427
- https://www.openwall.com/lists/oss-security/2019/08/26/1
- http://www.openwall.com/lists/oss-security/2019/08/26/1
- https://softwarepublico.gov.br/gitlab/pw3270/principal/compare/efa4ab249821ec351ae986683371043b8ca3c2ea...ff2b10fd56cf1fdae862b44bb0610e20e08de427
- https://www.openwall.com/lists/oss-security/2019/08/26/1
Get alerted when CVE-2019-15525 or the next vulnerability affects your stack